Output Resolution

irisg_guy
Posts: 14
Joined: Wed Jan 30, 2019 1:50 pm
4kOpen Owner: Yes
Re: Output Resolution

Post by irisg_guy » Fri Feb 08, 2019 1:58 pm

fbset output to follow...

irisg_guy
Posts: 14
Joined: Wed Jan 30, 2019 1:50 pm
4kOpen Owner: Yes
Re: Output Resolution

Post by irisg_guy » Fri Feb 08, 2019 2:03 pm

mode "1920x1080-50"
# D: 148.500 MHz, H: 56.250 kHz, V: 50.000 Hz
geometry 1920 1080 1920 1080 24
timings 6734 148 528 36 4 44 5
hsync high
vsync high
rgba 8/16,8/8,8/0,0/0
endmode

MattMunro
Posts: 11
Joined: Mon Oct 08, 2018 10:49 am
4kOpen Owner: Yes
Re: Output Resolution

Post by MattMunro » Fri Feb 08, 2019 3:50 pm

Hi,
I've done some testing and as far as I can tell this works for me, is it possible that stmfb.conf didn't save properly? Along with this are you using the latest Raspsbian version from the software download page?
Thanks,
Matt

irisg_guy
Posts: 14
Joined: Wed Jan 30, 2019 1:50 pm
4kOpen Owner: Yes
Re: Output Resolution

Post by irisg_guy » Fri Feb 08, 2019 4:41 pm

Thanks Matt...

I did download the latest version from the website... I think. How can I check what version is on the board?

fourkopen@4kopen:/etc/modprobe.d $ uname -r
3.10.92-stih418_family

Any chance you could copy and paste the stmfb.conf file you used here? Hers is my file..

fourkopen@4kopen:~ $ cd /etc/modprobe.d/
fourkopen@4kopen:/etc/modprobe.d $ cat stmfb.conf
# Generated by sdk2-build-master/modprobe.d/stmfb.conf template

# Tutorial:
# display0=1280x720-32@50:24320k:128m:ntsc:yuv:yuv is remaining the main display
# display0 is defined to set main output:
# Example of usage:
# display0=1280x720-32@50:24320k:128m:ntsc:yuv:yuv
# If board is supporting AUX display we should set for example:
# display1=720x576-16@50i:3m:0:pal:cvbs is remaining for AUX display when AUX_EN=1 in the automatic generation
# display1=720x576-16@50i:3m:0:pal:cvbs
# Depending on standards used you need to select
# For EU standard: @50 hz, ntsc mode and height 480
# For USA standard: @59 hz, pal and height 576
# /usr/bin/stfbset -f /dev/fb1 -a 0 -M 0x10101060; is defined to configure AUX output setting for transparency and Mixer background
# Example of usage:
# /usr/bin/stfbset -f /dev/fb1 -a 0 -M 0x10101060;

alias fb0 stmfb

options stmfb display0=3840x2160-32@50:64m:128m:ntsc:yuv:yuv \
display1=720x576-16@50i:3m:0:pal:cvbs

###########
# LOADING #
###########

# Load stmfb
install stmfb \
/sbin/modprobe coredisplay; \
/sbin/modprobe --ignore-install stmfb; \
/usr/bin/stfbset -a 0 -M 0x10101060; \
/usr/bin/stfbset -f /dev/fb1 -a 0 -M 0x10101060;

#############
# UNLOADING #
#############

# Unload stmfb
remove stmfb \
/sbin/modprobe -r --ignore-remove stmfb; \
/sbin/modprobe -r coredisplay

irisg_guy
Posts: 14
Joined: Wed Jan 30, 2019 1:50 pm
4kOpen Owner: Yes
Re: Output Resolution

Post by irisg_guy » Fri Feb 08, 2019 4:42 pm

Raspian Version....

fourkopen@4kopen:/etc/modprobe.d $ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 9.4 (stretch)
Release: 9.4
Codename: stretch

MattMunro
Posts: 11
Joined: Mon Oct 08, 2018 10:49 am
4kOpen Owner: Yes
Re: Output Resolution

Post by MattMunro » Fri Feb 08, 2019 4:53 pm

This is the conf I used, it looks to be identical to yours.
Also the last Raspbian update was a month ago if I recall, so since you got your board recently It should be fine.
I'll continue looking into it but I'm unsure what the problem is currently.

Code: Select all

# Generated by sdk2-build-master/modprobe.d/stmfb.conf template

# Tutorial:
# display0=1280x720-32@50:24320k:128m:ntsc:yuv:yuv is remaining the main display
# display0 is defined to set main output:
# Example of usage:
# display0=1280x720-32@50:24320k:128m:ntsc:yuv:yuv
# If board is supporting AUX display we should set for example:
# display1=720x576-16@50i:3m:0:pal:cvbs is remaining for AUX display when AUX_EN=1 in the automatic generation
# display1=720x576-16@50i:3m:0:pal:cvbs
# Depending on standards used you need to select
# For EU standard: @50 hz, ntsc mode and height 480
# For USA standard: @59 hz, pal and height 576
# /usr/bin/stfbset -f /dev/fb1 -a 0 -M 0x10101060; is defined to configure AUX output setting for transparency and Mixer background
# Example of usage:
# /usr/bin/stfbset -f /dev/fb1 -a 0 -M 0x10101060;

alias fb0 stmfb

options stmfb display0=3840x2160-32@50:64m:128m:ntsc:yuv:yuv \
                      display1=720x576-16@50i:3m:0:pal:cvbs

###########
# LOADING #
###########

# Load stmfb
install stmfb \
/sbin/modprobe coredisplay; \
/sbin/modprobe --ignore-install stmfb; \
/usr/bin/stfbset -a 0 -M 0x10101060; \
/usr/bin/stfbset -f /dev/fb1 -a 0 -M 0x10101060;

#############
# UNLOADING #
#############

# Unload stmfb
remove stmfb \
/sbin/modprobe -r --ignore-remove stmfb; \
/sbin/modprobe -r coredisplay

irisg_guy
Posts: 14
Joined: Wed Jan 30, 2019 1:50 pm
4kOpen Owner: Yes
Re: Output Resolution

Post by irisg_guy » Fri Feb 08, 2019 6:39 pm

Thanks Matt...

I will run a file compare on Monday when back at work...

MattMunro
Posts: 11
Joined: Mon Oct 08, 2018 10:49 am
4kOpen Owner: Yes
Re: Output Resolution

Post by MattMunro » Mon Feb 11, 2019 9:54 am

Hi,
It occurs to me that there is a slight difference between booting from SD card and USB, all of my testing has been done through a USB device. Which are you using?
Thanks, Matt
PS. if you are using an SD card, the development version has "./etc/udev/rules.d/90-qemu.rules" removed, I'm unsure if this will solve your problem as I only know it was to do with the SD card booting. I'd move it somewhere safe (such as your Document directory) just encase as I don't know why this hasn't been pushed yet.

irisg_guy
Posts: 14
Joined: Wed Jan 30, 2019 1:50 pm
4kOpen Owner: Yes
Re: Output Resolution

Post by irisg_guy » Wed Feb 13, 2019 5:37 pm

Hi Matt,
Yes I am booting from SD card... I will try to remove that file and then I will test running from USB...

Appreciate your help.

Louis

irisg_guy
Posts: 14
Joined: Wed Jan 30, 2019 1:50 pm
4kOpen Owner: Yes
[RESOLVED] Re: Output Resolution

Post by irisg_guy » Fri Feb 15, 2019 10:52 am

Ok... got it working :)

I put the OS on the USB key and make the changes to the stmfb.conf file. It still did not work but now it did not default to 1080p. I tested another monitor and it worked perfect.

Thanks for your help.
Louis


Post Reply